Welcome to gadgetPool.de!
gadgetPool
Homepage
Projekt veröffentlichen
Artikel schreiben
Projekte lesen
Artikel lesen
Forum
Diskussionen Ideen Vorschläge
Downloads
Treiber Dateien Datenblätter
Anmeldung
Passwort Mail Einstellungen

     Menue
WebShop
Hier gibt's die gadgets

     Languages
Sprache für das Interface auswählen

English German

     Login
Benutzername

Passwort

Kostenlos registrieren!. Gestalten Sie Ihr eigenes Erscheinungsbild. Passen Sie das Seitenlayout Ihren Wünschen an

gadgetPool.de: Forum

gadgetPool.de :: View topic - Problem connecting to Raymarine autopilot
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log inLog in 

Problem connecting to Raymarine autopilot

 
Post new topic   Reply to topic    gadgetPool.de Forum Index -> Nmea Multiplexer with SeaTalk I/O
View previous topic :: View next topic  
Author Message
Johnathan
Newbie
Newbie


Joined: Mar 12, 2012
Posts: 6

PostPosted: Tue Apr 07, 2015 7:32 am    Post subject: Problem connecting to Raymarine autopilot Reply with quote

Hi

I am having some problems and perhaps you can advise me please.

I am trying to connect several devices via the multiplier, these include
Gps
Seatalk bus with dept and wind
A furuno 1834c plotter
A furuno fluxgate compass pg-500
A raymarine s3 autopilot

I have successfully set the mux to collect the gps and seatalk signals and broadcast them out however I am having problems with the auto pilot.

The auto pilot is connected on the seatalk bus (I am not converting any nmea data to seatalk), but needs two nmea signals, 1, true heading info from the fluxgate and 2, gps waypoint, bearing information when tracking to a point via the plotter.
I wanted to push all data via the mux to filter any echoes from devices that relay the inbound signal, but I have been unable to do this with the flux gate heading info and plotter provided waypoint info.

If I connect the fluxgate to the mux I can see the data on the USB port, if I the Connect a mux output to the raymarine autopilot nmea in, then the autopilot reports "no comp" ie no compass signal. If I connect the fluxgate to the autopilot directly, ie bypass the mux then the autopilot works fine.

I am confused by this behaviour.
The same thing happens with the position output from the plotter to the autopilot, via the mux it is not received /understood by the autopilot, but a direct connection works.

I have removed all filters, and the baud rates remain the default.

Do you have any suggestions?

Johnathan
Back to top
View user's profile Send private message
FWallenwein
Site Admin
Site Admin


Joined: Mar 26, 2006
Posts: 417
Location: Mannheim / Germany

PostPosted: Sun Apr 12, 2015 6:45 pm    Post subject: Reply with quote

Hi Johnathan,

sorry for the delay. I've been away and didn't check for new postings in the forum and so I missed your questions. Sorry about that.

Well - your Problem is strange indeed.
Apparently the muxer does receive the fluxgate and GPS data.
You can see it on the USB port...
All filters are off....

Well - than it should send it out to the NMEA-OUT Ports as well.
No doubt about that.

But the autopilot apparently does not see this data.
I don't understand this as well.

What could we do ?

- Check if the Multiplexer actually does send it out.
Do you, by chance, hase a serial port on your PC ?
Or maybe a Serial->USB converter at hand ?
In that case, we could connect a NMEA out Port to the PC serial port and monitor if the data arrive. With this we could find out if it's a software/setting/filter problem or if the multiplexer actually DOES send the data and the autopilot can not read it for some reason.

- Did you try a different NMEA-OUT port ?
Should not - but you never know. A NMEA-OUT port could be damaged.

You surely have the latest firmware on the multiplexer ? In old firmwareversions only NMEA-OUT 1 and 2 are available.

Could you tell me which NMEA-OUT port you are using and what is connected at the NMEA-IN of this chanel ?

Not really sure why I'm asking this. I'm just trying to get information so that maybe I can set up a simmilar configuration here for testing.
Unfortunately I don't have a S3 Autoplilot or a Furuno Fluxgate here though.

- I'm sure you checked that NMEA-OUT+ and NMEA-OUT- is not interchanged.
I know - stupid question. Just tring to find a reason.


Just out of curiostiy.
You could - if you like - just temporarily switch on sending seatalk and see what happens. If the autopilot receives heading/waypoints over SeaTalk, we would know, that the bridge does receive it correct and that it recognized the NMEA sentence.

Another thing we could think about.
I rememer I once had a NMEA VHF which did not receive NMEA data as well. It turned out, that this VHF needed to have a wire between it's GND ( Minus ) and the GND ( Minus ) of the SeaTalk NMEA Bridge.
( That was a bridge, not a multiplexer - but anyway. )
We never really found out what was the reason for this. But on this boat, it worked.

So far for today,

Best regards
Frank
Back to top
View user's profile Send private message Visit poster's website
Johnathan
Newbie
Newbie


Joined: Mar 12, 2012
Posts: 6

PostPosted: Mon Apr 13, 2015 5:38 pm    Post subject: Reply with quote

Hi Frank

I will not be back at my boat until the weekend, and I will triple check everything.
I did try to send the data via Seatalk but this did not appear to work.

It's hard to debug the autopilot, it generally displays "no comp" if it returns no magnetic or true data is received. Then if following a route when switching to track mode it shows "no data" if it does not get the Nmea waypoint bearing data.

I could be wrong, but I did double check it, and I have spent 10s of hours with different configurations.

Initially my electronics was chained together nmea out to nmea in. Then the flux gate was connected directly to the plotter via its own system to enable the radar overlay ( required always). The fluxgate then relayed nmea separately to a repeater.
At serveral times last year I had one device crash, this crashed everything and took the auto offline. My goal with the mux is to put this as the central hub and filter signals out of this so each device is independent.

Potentially confusing is the foruno chart plotter. It has 3 nmeas I/o s. Data 1 takes gps in, data 2 is the only one to output the wpt nmea and data 4 has as rs232 input that will accept route data inbound. The info on this is poor, so ideally I wanted to provide minimal data to each port filtered by the mux.

I started adding one single device signal at a time, watching it on the usb terminal window. I've worked a lot with serial coms and arduino mps so I feel reasonably confident but I could be wrong and I will check again.

To confirm my observations:
Flux connected to mux, mux out to auto - the correct nmea is seen on the USB port but the auto says "no comp"

Remove the mux and just join the auto to the compass and it works.

The auto has 2 nmea ports, so if I use the second to send the route data, so then I connect the plotter to the mux and the mux to the auto on nmea in 2 and the auto say "no data". Remove the mux and connect the wires directly and it works.

The flux sends data at I guess 5 Hz, when connect to the mux the signal can been seen on the repeater instrument correctly. But I notice it does load the buffer Highly. One strange observation is that enabling the true wind speed calc and having the flux connected really maxes the in / out buffers.

I can't get the plotter to receive a rs232 route from a pc via the mux, but to be fair I have not debugged this in detail.

Seatalk data to nmea works fine, and is muxed correctly with gps and sent to a repeater and plotter. Strangely the repeater only works with the apparent wind.


I will re check everything and report back.

Johnathan
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    gadgetPool.de Forum Index -> Nmea Multiplexer with SeaTalk I/O All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001-2003 phpBB Group
phpBB port v2.0.7 based on Tom Nitzschner's phpbb2.0.6 upgraded to phpBB 2.0.7 standalone was developed and tested by:
ChatServ, mikem,
and Paul Laudanski (aka Zhen-Xjell).

Version 2.0.7 by Nuke Cops © 2004 http://www.nukecops.com
Forums ©




All logos and trademarks in this site are property of their respective owner. The comments are property of their posters, all the rest © 2006-2015 by gadgetPool.


PHP-Nuke Copyright © 2005 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Erstellung der Seite: 0.05 Sekunden